PDA

View Full Version : help: How to transfer data?



vinu
12th July 2006, 04:09 AM
Hi everybody,

I have a problem with data tranfer.
I need to transfer a huge amount of data (more than 100 GB) from
a remote PC to my PC.

I use;

scp -r name@host.domain:/dir/data/ .

But the problem is, connection breaks down and the tranfer stalled.
The SCP does not resume tranfer by itself (i think so because it
never happened for me).

I use Fedora-4.

1) Is there any other effective way for tranfer?

2) Is there any option that we can set up SCP with resume mode?

3) I know about WGET which resumes tranfer even after a breakdown.
Is that possible to use for remote pc (i mean not server) ?

Thanks in advance

-Vinu

praveen
15th July 2006, 06:40 AM
Hi ,

I used NCFTP client for up to 5GB. I never had a situation to transfer morethan this, anyway try this one. I think it should work.

U can have source /Binaries in this page

http://www.ncftp.com/download/

command: ncftp -u username -p password system@domain.ca

U can avoid using argument -p password in above line. It can ask password, once the connection is established.

ncftpget can be used instead of wget for downloading from extrnal links, which can handle big files than wget.

let me know the result pls.

vinu
19th July 2006, 10:09 AM
Hi Praveen,

Thank you for your input. But, unfortunately I could not
operate ncftp successfully. I have installed the 'ncftp' client
from the above website and tried it. It didnt connect the server
with the command
ncftp -u username -p password system@domain

my remote host is 'salmon' and domain is 'ees.hokudai.ac.jp'.

and the result is it gives me this error:

NcFTP 3.1.9 (Mar 24, 2005) by Mike Gleason (http://www.NcFTP.com/contact/).Resolving salmon@ees.hokudai.ac.jp...
Unknown host "salmon@ees.hokudai.ac.jp".


Is the way 'system@domain' is correct?
I also tried a combination as 'system.domain', but connection refused.

Is the remote pc need ncftp server installed?

Later i switched to 'rsync', although the results are not
satisfactory. However it is better than 'scp'.

I also doubt whether the remote pc that I am trying to access has
some control or firewall. 'rsync' also fails with this error.


rsync error: error in rsync protocol data stream (code 12) at io.c(420)
rsync: connection unexpectedly closed (73 bytes received so far) [generator]rsync error: error in rsync protocol data stream (code 12) at io.c(420)

now I am transfering files one by one.


-Thanks

-

rocksea
20th July 2006, 02:32 AM
most of the common terminals/servers here at hokudai dont allow ftp. rsync should have worked and it copies new files only and would have been very convenient (i.e. it is like continuing your transfer even after getting disconnected).

have you tried to ssh and login on the remote pc and then ftp (or other transfers) to your pc?

praveen
20th July 2006, 04:08 AM
hi vinu,
I think the problem is ftp settings in ur host (japan). they might have secured as Roxy mentioned. There is no need to have Ncftp in ur host to connect. but it should have proper usual ftp settings thats all.
"system.domain" is the correct way. Try ping to check the working status of host like
"ping system.domain", then u can get the ip address. once u have ip then Ncftp command is straight forward

ncftp -u username ipaddress

Try this command "ncftp -u vinukv parthia.eas.ualberta.ca"

It works right?.. So the problem is host :mad:

As I said, i used this client for a single file having size of 5GB.

did u tried "sftp"? is that one also have transfer limit.

command
---------------
sftp vinukv@salmon.ees.hokudai.ac.jp

:icon_albi

When i googled through web. I found some interesting things like, Network connection timeout settings. So those settings can affect the long time duration transfer.

42d3e78f26a4b20d412==